Configurar VLANs em Switches Cisco.

Hoje estarei descrevendo como configurar VLAN’s e como realizar a comunicação da VLAN em ambientes Cisco.

Abaixo está o cenário proposto.

Cenário VLAN

Os 3 computadores do nosso cenário estão com os IPs Fixos. Agora, temos que configurar a porta que o host está, falo host porque pode ser um Computador, um Access Point, uma impressora, um Telefone IP e etc. Como sabemos temos que configurar cada VLAN em uma Rede IP diferente, abaixo segue a sugestão para o nosso cenário.

VLAN 20 – 10.10.20.0/24

VLAN 30 - 10.10.30.0/24

VLAN 40 - 10.10.40.0/24

Pronto, agora vamos configurar o Switch.

Switch(config)#inter f0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit

Switch(config)#inter f0/3
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 30
Switch(config-if)#exit

Switch(config)#inter f0/4
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 40
Switch(config-if)#exit

Podemos verificar as configurações da VLAN com o comando abaixo:

Switch#sho vlan brief

VLAN Name                             Status    Ports

—- ——————————– ——— ——————————-
1    default                                            active    Fa0/1, Fa0/5, Fa0/6, Fa0/7
Fa0/8, Fa0/9, Fa0/10, Fa0/11
Fa0/12, Fa0/13, Fa0/14, Fa0/15
Fa0/16, Fa0/17, Fa0/18, Fa0/19
Fa0/20, Fa0/21, Fa0/22, Fa0/23
Fa0/24

20   VLAN0020                                active    Fa0/2
30   VLAN0030                                active    Fa0/3
40   VLAN0040                                active    Fa0/4
1002 fddi-default                              active
1003 token-ring-default                 active
1004 fddinet-default                        active
1005 trnet-default                            active

Podemos observar que a porta 2 está na VLAN 20, que a porta 3 está na VLAN 30 e que a porta 4 está na VLAN 40.

Pronto, os 3 computadores do nosso cenário estão no mesmo Switch, porém em redes diferentes.

Agora se precisarmos que os 3 computadores consigam se comunicar, temos que configurar o Router para realizar o roteamento dessas VLANs, que estão em redes diferentes, então, pra que possamos realizar a comunicação de VLAN’s diferentes, temos que ter um dispositivo de camada 3, nesse nosso cenário é um Router. Primeiro temos que configurar a porta do Switch que está ligado ao Router como Trunk, com isso a porta em modo Trunk consegue encaminhar o tráfego de outras VLANs.

Segue a configuração do modo Trunk na porta do Switch que o Router está conectado.

Switch(config)#inter f0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan 20
Switch(config-if)#switchport trunk allowed vlan add 30
Switch(config-if)#switchport trunk allowed vlan add 40

Agora temos que configurar sub-interfaces e endereçamento IP no Router para que ele consiga rotear os pacotes entre as VLAN’s.

Router(config)#inter f0/0
Router(config-if)#no shutdown
Router(config-if)#exit

Router(config)#inter f0/0.20
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 10.10.20.1 255.255.255.0
Router(config-subif)#exit

Router(config)#inter f0/0.30
Router(config-subif)#encapsulation dot1Q 30
Router(config-subif)#ip address 10.10.30.1 255.255.255.0
Router(config-subif)#exit

Router(config)#inter f0/0.40
Router(config-subif)#encapsulation dot1Q 40
Router(config-subif)#ip address 10.10.40.1 255.255.255.0
Router(config-subif)#exit

Pronto, criada as sub-interfaces, podemos agora tentar testar a conectividade com um outro PC que está em outra VLAN.

PC>ipconfig

IP Address………………….: 10.10.40.10
Subnet Mask…………………: 255.255.255.0
Default Gateway……………..: 10.10.40.1

PC>ping 10.10.20.10

Pinging 10.10.20.10 with 32 bytes of data:

Reply from 10.10.20.10: bytes=32 time=13ms TTL=127
Reply from 10.10.20.10: bytes=32 time=9ms TTL=127
Reply from 10.10.20.10: bytes=32 time=16ms TTL=127
Reply from 10.10.20.10: bytes=32 time=10ms TTL=127

Ping statistics for 10.10.20.10:
Packets: Sent = 4, Received= 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 9ms, Maximum = 16ms, Average = 12ms

Yeah!!! Sucesso!!! O PC está na VLAN 40 e conseguiu pingar na em um host da VLAN 20.

Deus abençoe a todos.

About these ads

Trabalho como Analista de Suporte na empresa Solutis Tecnologias em Salvador/Ba. Atuo na área de Tecnologia da Informação há 12 anos, Pós-Graduando em Gestão da Segurança da Informação pela Unijorge (Salvador/Bahia). Certificado ITIL Foundation e FCP Fundamental.

Publicado em Computadores e a Internet, Redes
19 comments on “Configurar VLANs em Switches Cisco.
  1. junior disse:

    muito obrigado , edvan pela ajuda , ja refiz a divisao de sub rede , agora ficou legal,,, um abracao e obrigado por compartilhar conhecimento,, junior / sorocaba-sp

  2. junior disse:

    ola edvan , queria te pedir vossa ajuda , estou configurando um roteador cisco(1941) e uma switch cisco (2960) , tenha duas subredes A , B , na rede A tenho 1 usuario , na rede B tenho 20 usuarios .a configuracao que tenho eo IP 192.168.25.0 ( somente este IP disponivel) , dividi em 2redes , A= 192.168.25.1 e 192.168.25.2 ( 255.255.255.252/30 )
    B = 192.168.25.1 ate 192.168.25.30 ( 255.255.255.224/27 ) . tenho o roteador na porta G0/0 ligado a rede A , na porta G0/1 ligado na porta da switch F0/24 indo para rede B .. meu problema EDVAN ,quando vou configurar os IP,S nas portas G0/0 e G0/1 do roteador ela me da uma mensagemde erro ( ip address overlap ).. obrigado ,, junior / sorocaba.sp

    • Edvan Barros disse:

      Junior,

      O problema é que vc dividiu a sub-rede errada, se a Rede A está 192.168.25.0/30 (.1 e .2), a sub-rede B tem que começar na próxima sub-rede disponível, que seria 192.168.25.4, com a mascara que vc colocou /27.

  3. lucas disse:

    Perfeito!

  4. eduardofox disse:

    Muito bom cara, o que eu tava precisando

    • eduardofox disse:

      Por que não posso configurar duas VLANS distintas na mesma rede? O trabalho do protocolo 802.1Q não é simplesmente separar o domínio de broadcast de cada vlan? Ou seja, mesmo ela estando com a mesma rede de outra vlan, não haveria comunicação entre as duas.

  5. como faço para dividir minha rede em varias vlan?
    Tenho um router linux “PFSense” > switch L3 “sg300 CISCO” e varios switch l2 não gerenciaveis.

  6. Vinicius Tuler disse:

    Não estou conseguindo configurar a próxima sub-interface. Está acusando a seguinte mensagem:
    10.0.0.0 overlaps with FastEthernet0/0.20

    Ele está bloqueando a configuração na mesma sub-rede.

    Por que ?

  7. Marcelo Natera disse:

    Ótimo tutorial, bem direto !!! Parabens !

    Tenho um cenário um pouco diferente aqui e rolaram algumas dúvidas !
    Possuo uma porta access do meu switch core ligada ao Cisco ASA (de onde vem meu acesso WAN). Como realizo a configuração para uma Vlan nova comunicar com as demais, a porta de entrada de dados do switch é access e não trunk ?!

  8. Rafael Queiroz disse:

    Otimo tutorial.. Estou tentando utiliza-lo para um switch da CISCO (Catalyst 3750). Ele possui sistema de roteamento dentro dele e estou com dificuldades para configurar esta situação. Não estou conseguindo comunicação entre vlans.

    Se puder me ajudar, ficaria muito grato.
    []‘s

    • Rafael Queiroz disse:

      Consegui resolver meu problema.
      Para utilizar comunicação entre vlans onde o router é o proprio switch, no meu caso – catalyst 3750, precisei criar um trunk para cada vlan, configura-lo como o exemplo acima, configurar vtp, configurar o spanning vlans e adicionar as vlans na database do router, fazendo assim:

      SW#vlan database
      SW(vlan)#vlan 18
      SW(vlan)#vlan 20
      SW(vlan)# exit

      Continue postando exemplos, esse foi de muita ajuda.
      []‘s

  9. henrique disse:

    Colega Edvan,

    tenho uma pequena dúvida …. Como eu faço para com as vlans citadas no exemplo vlan 20 , 30 ,40 utilize o link do switch para chegar ao roteador (das vlans chegarem ao roteador e ter acesso externo) mais não obter a comunição entre as vlans.
    Por que eu conseguir fazer isso criando as sub-if 20.30.40 ok funcionou a comunicação das vlans com roteador o problema é que há comunicação entre vlans tambem. posso bloquear esse tráfego ? colocar apenas a porta trunk para acesso externo das vlans?

    • Edvan de Barros Silva disse:

      Henrique,

      Você pode bloquear a comunicação entre as VLANS utilizando ACL no Router.

      • henrique disse:

        Tu poderias mandar um exemplo da acl como ficaria ?

        desde já agradeço!

      • henrique disse:

        Pode se fazer bloqueio das vlans por end físico, e não por IP
        para não haver a comunicação intra-vlan?
        motra um ex: da ACL se caso tiver.

  10. Israel Teixeira disse:

    Prezado,

    programei conforme o script mas não funcionou, o que pode ser?

    Abraços,
    israel teixeira

  11. Delcio disse:

    boa dica valeu

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

Seguir

Obtenha todo post novo entregue na sua caixa de entrada.

Junte-se a 866 outros seguidores

%d blogueiros gostam disto: